summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward Thomson <ethomson@edwardthomson.com>2023-03-27 11:58:14 +0100
committerGitHub <noreply@github.com>2023-03-27 11:58:14 +0100
commit9bfad74dc029f163f296d09df56a42b97a38f4c1 (patch)
tree5b8b1f1e77c16a375b5f3d8dddc366643862846f /CMakeLists.txt
parentc058aa87dce4c67a3b86b3349beebd64b7bedcd3 (diff)
parentf15c8ac71a916bf186cd5ff81f07ca85eef82afb (diff)
downloadlibgit2-9bfad74dc029f163f296d09df56a42b97a38f4c1.tar.gz
Merge pull request #6533 from libgit2/ethomson/schannel-2
Introduce Schannel and SSPI for Windows
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 94627f54d..fa5167538 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -82,12 +82,6 @@ if(MSVC)
option(WIN32_LEAKCHECK "Enable leak reporting via crtdbg" OFF)
endif()
-if(WIN32)
- # By default, libgit2 is built with WinHTTP. To use the built-in
- # HTTP transport, invoke CMake with the "-DUSE_WINHTTP=OFF" argument.
- option(USE_WINHTTP "Use Win32 WinHTTP routines" ON)
-endif()
-
if(NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE "Debug" CACHE STRING "Choose the type of build, options are: Debug Release RelWithDebInfo MinSizeRel." FORCE)
endif()