summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward Thomson <ethomson@edwardthomson.com>2021-11-06 16:38:11 -0400
committerEdward Thomson <ethomson@edwardthomson.com>2021-11-11 15:56:10 -0500
commit7b527c12bc07d61fb6d2f0d7bb0b35815dbae49d (patch)
tree7753c468edaa650db908ff680feab2d8fb64cf92 /CMakeLists.txt
parent9f37457e17f1b1f9e899b757df3413180719005f (diff)
downloadlibgit2-7b527c12bc07d61fb6d2f0d7bb0b35815dbae49d.tar.gz
cmake: move deprecation definition to src/
There's no need to add the deprecation at the top-level. Our tests add deprecation explicitly.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f7f19468c..46506590e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -103,10 +103,6 @@ include(DefaultCFlags)
# Compiler / linker flags
#
-if(DEPRECATE_HARD)
- add_definitions(-DGIT_DEPRECATE_HARD)
-endif()
-
if(NOT CMAKE_CONFIGURATION_TYPES)
# Build Debug by default
if(NOT CMAKE_BUILD_TYPE)