summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward Thomson <ethomson@edwardthomson.com>2021-11-15 07:45:16 -0500
committerEdward Thomson <ethomson@edwardthomson.com>2022-02-22 22:07:44 -0500
commit5fcfada500073ddd4acbfa0b0906e37025b45556 (patch)
tree598abca1f4fdfdf26fc68debaeb0216cf72eb1b2 /CMakeLists.txt
parentc3b7ace9cf3216928a31886b32c264e0cd3cde75 (diff)
downloadlibgit2-5fcfada500073ddd4acbfa0b0906e37025b45556.tar.gz
cmake: document CMakeLists.txt hierarchy
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eb137ecdd..90ecc92fe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,8 @@
-# CMake build script for the libgit2 project
+# libgit2: the cross-platform, linkable library implementation of git.
# See `README.md` for build instructions.
+#
+# This top-level CMakeLists.txt sets up configuration options and
+# determines which subprojects to build.
cmake_minimum_required(VERSION 3.5.1)