summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward Thomson <ethomson@edwardthomson.com>2021-09-26 22:06:49 -0400
committerEdward Thomson <ethomson@edwardthomson.com>2021-10-17 13:05:32 -0400
commit4e14d4c6a6d4629601cc7e1659df85eeb450df10 (patch)
tree3d232ff4acf836703620faa6a7bd6059c3d4f761 /CMakeLists.txt
parente61abdce434e17104b40c09b34094e2d571ba9e9 (diff)
downloadlibgit2-4e14d4c6a6d4629601cc7e1659df85eeb450df10.tar.gz
cmake: BUILD_CLAR is now BUILD_TESTSethomson/clar_no_more
Nobody knows what CLAR is. The test building option should be `BUILD_TESTS`.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3dccec310..81ef04f2a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,7 +38,7 @@ INCLUDE(EnableWarnings)
OPTION(SONAME "Set the (SO)VERSION of the target" ON)
OPTION(BUILD_SHARED_LIBS "Build Shared Library (OFF for Static)" ON)
OPTION(THREADSAFE "Build libgit2 as threadsafe" ON)
-OPTION(BUILD_CLAR "Build Tests using the Clar suite" ON)
+OPTION(BUILD_TESTS "Build Tests using the Clar suite" ON)
OPTION(BUILD_EXAMPLES "Build library usage example apps" OFF)
OPTION(BUILD_FUZZERS "Build the fuzz targets" OFF)
OPTION(ENABLE_TRACE "Enables tracing support" ON)
@@ -281,7 +281,7 @@ IF (NOT MSVC)
ENDIF()
ENDIF ()
-IF (BUILD_CLAR)
+IF (BUILD_TESTS)
ENABLE_TESTING()
ADD_SUBDIRECTORY(tests)
ENDIF ()
@@ -295,7 +295,7 @@ IF(BUILD_FUZZERS)
IF(BUILD_EXAMPLES)
MESSAGE(FATAL_ERROR "Cannot build the fuzzer targets and the examples together")
ENDIF()
- IF(BUILD_CLAR)
+ IF(BUILD_TESTS)
MESSAGE(FATAL_ERROR "Cannot build the fuzzer targets and the tests together")
ENDIF()
ENDIF()