summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward Thomson <ethomson@edwardthomson.com>2023-05-12 21:49:29 +0100
committerEdward Thomson <ethomson@edwardthomson.com>2023-05-12 21:49:29 +0100
commit333573857960fa7260f01f38a2003bafa2313a87 (patch)
treec6f919f9838b2af376facb64699360ae1b803baa /CMakeLists.txt
parent767a9a733ca64928d395318a9cda47822241b879 (diff)
downloadlibgit2-333573857960fa7260f01f38a2003bafa2313a87.tar.gz
cmake: refactor `check_prototype_definition`
Introduce `check_prototype_definition_safe` that is safe for `Werror` usage.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 30527b928..cfb5a7d6f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -94,7 +94,7 @@ include(CheckLibraryExists)
include(CheckFunctionExists)
include(CheckSymbolExists)
include(CheckStructHasMember)
-include(CheckPrototypeDefinition)
+include(CheckPrototypeDefinitionSafe)
include(AddCFlagIfSupported)
include(FindPkgLibraries)
include(FindThreads)