summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward Thomson <ethomson@edwardthomson.com>2021-08-25 12:20:50 -0400
committerGitHub <noreply@github.com>2021-08-25 12:20:50 -0400
commit0850b1722cbd5095aa6f6e307b9c1bac49228d53 (patch)
tree3f5634b935981136f651c7bcc3f0dd48dbf0a61c /CMakeLists.txt
parentcc4f8bc65e7dfc6673b83645b2f323bf555088e8 (diff)
parent4584660e11ee5fd6e9fb44b0d00bf7cb8df8edb4 (diff)
downloadlibgit2-0850b1722cbd5095aa6f6e307b9c1bac49228d53.tar.gz
Merge pull request #5950 from boretrk/posixtest
open: input validation for empty segments in path
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 96bdb4cf0..a9f544174 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -51,6 +51,7 @@ OPTION(USE_STANDALONE_FUZZERS "Enable standalone fuzzers (compatible with gcc)"
OPTION(USE_LEAK_CHECKER "Run tests with leak checker" OFF)
OPTION(DEBUG_POOL "Enable debug pool allocator" OFF)
OPTION(DEBUG_STRICT_ALLOC "Enable strict allocator behavior" OFF)
+OPTION(DEBUG_STRICT_OPEN "Enable path validation in open" OFF)
OPTION(ENABLE_WERROR "Enable compilation with -Werror" OFF)
OPTION(USE_BUNDLED_ZLIB "Use the bundled version of zlib. Can be set to one of Bundled(ON)/Chromium. The Chromium option requires a x86_64 processor with SSE4.2 and CLMUL" OFF)
SET(USE_HTTP_PARSER "" CACHE STRING "Specifies the HTTP Parser implementation; either system or builtin.")