summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMayank Sharma <mayank8019@gmail.com>2019-07-16 15:28:33 +0530
committerMayank Sharma <mayank8019@gmail.com>2019-07-16 15:39:19 +0530
commit8760c297909a5e13047d6db7f09c40fa7cf60123 (patch)
tree313dd969708402f689b74532ad4e2028e8a80522 /meson.build
parentb653f602b3c2b518101c5d909e1651534c22757a (diff)
downloadlibgdata-8760c297909a5e13047d6db7f09c40fa7cf60123.tar.gz
meson: Fix G_LOG_DOMAIN for shared_library as well as demos
Currently, libgdata's debug output come from empty log domain. This interferes when libgdata's debug output needs to be separate from any client which is trying to use it. This commit fixes G_LOG_DOMAIN for libgdata as well as all the demos (which have their own log domains). Fixes: https://gitlab.gnome.org/GNOME/libgdata/issues/30
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 36d8cc1c..ad2b0140 100644
--- a/meson.build
+++ b/meson.build
@@ -53,6 +53,7 @@ config_h.set_quoted('VERSION', gdata_version)
config_h.set('_GNU_SOURCE', true)
config_h.set_quoted('GETTEXT_PACKAGE', 'gdata')
+config_h.set_quoted('G_LOG_DOMAIN', gdata_name)
gnome = import('gnome')
pkgconfig = import('pkgconfig')