summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHans <h-c-mueller@users.noreply.github.com>2022-09-18 01:56:25 +0200
committerGitHub <noreply@github.com>2022-09-17 19:56:25 -0400
commitee22ecbd11f52f8de1adbb2a6561aee2125a576a (patch)
tree7db565ad12b2bc7ec66a5b20b964e377415bb67c /configure.ac
parent5e010474cf2e30fa053f0a1a460a752f06438cf7 (diff)
downloadlibffi-ee22ecbd11f52f8de1adbb2a6561aee2125a576a.tar.gz
Add MSYS configuration files (#728)
* Add MSYS configuration files MSYS behaves very similiar to Cygwin, e.g. also __CYGWIN__ is defined. Now 'make check' passes on MSYS without extra patches. * Fix warning extra tokens at end of #endif in closures.c Extra tokens converted into a comment. Also nearby indentations corrected. * Fix missing prototype warning mkostemp() on Cygwin Cygwin requires also _GNU_SOURCE to be defined to enable mkostemp() prototype. * Fix warning label ‘out’ defined but not used in ffi functions Define same preprocessor conditions for goto and label visibility. * Fix warning label ‘out’ defined but not used and related indentations. Define same preprocessor conditions for goto and label visibility. Correct also related indentations. Co-authored-by: Hannes Müller <>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 75cc455..fba64d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -391,7 +391,7 @@ AC_ARG_ENABLE(exec-static-tramp,
if test "$enable_exec_static_tramp" != no; then
case "$target" in
- *-cygwin*)
+ *-cygwin* | *-msys*)
# Only define static trampolines if we are using the cygwin runtime.
# Will this need to be changed for mingw?
if test "x$GCC" = "xyes"; then