summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHans <h-c-mueller@users.noreply.github.com>2022-09-19 23:26:59 +0200
committerGitHub <noreply@github.com>2022-09-19 17:26:59 -0400
commite3eaa609882fbcffb6c1b21270b6ff46fb57699f (patch)
treed84ed9f77144df83440cd97640cb6e82ab59ece8 /configure.ac
parent84817695eab13c282436fca278bde2384ca955e5 (diff)
downloadlibffi-e3eaa609882fbcffb6c1b21270b6ff46fb57699f.tar.gz
Suppress error console output duing configure in case not an ELF file (#729)
On Cygwin, MSYS and MinGW readelf is available, but files generated are no ELF files. This results in an Error output on console: 'checking whether .eh_frame section should be read-only... readelf: Error: Not an ELF file - it has the wrong magic bytes at the start yes' With this patch the error output is suppressed resulting in only 'checking whether .eh_frame section should be read-only... yes' Setting of related variables is not changed. Co-authored-by: Hannes Müller <>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ed394c9..0ac8b76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -294,7 +294,7 @@ if test "x$GCC" = "xyes"; then
libffi_cv_ro_eh_frame=yes
echo 'extern void foo (void); void bar (void) { foo (); foo (); }' > conftest.c
if $CC $CFLAGS -c -fpic -fexceptions $libffi_cv_no_lto -o conftest.o conftest.c > /dev/null 2>&1; then
- if $READELF -WS conftest.o | grep -q -n 'eh_frame .* WA'; then
+ if $READELF -WS conftest.o 2>/dev/null | grep -q -n 'eh_frame .* WA'; then
libffi_cv_ro_eh_frame=no
fi
fi