summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAnthony Green <green@moxielogic.com>2018-03-27 08:05:42 -0400
committerAnthony Green <green@moxielogic.com>2018-03-27 08:05:42 -0400
commitd3693b4665de7ef69b61fb4e483d5686302f9c69 (patch)
treed9bbdeb3bed67f60e89b2158290dcc1be8113c65 /configure.ac
parent51ce3696cd0da4716d86b73a30bd89e139ec4b74 (diff)
downloadlibffi-d3693b4665de7ef69b61fb4e483d5686302f9c69.tar.gz
Copy - don't symlink - to support msvc builds
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2964a3c..052ca8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -381,8 +381,10 @@ test -d src || mkdir src
test -d src/$TARGETDIR || mkdir src/$TARGETDIR
], [TARGETDIR="$TARGETDIR"])
-AC_CONFIG_LINKS(include/ffitarget.h:src/$TARGETDIR/ffitarget.h)
-
AC_CONFIG_FILES(include/Makefile include/ffi.h Makefile testsuite/Makefile man/Makefile doc/Makefile libffi.pc)
AC_OUTPUT
+
+# Copy this file instead of using AC_CONFIG_LINK in order to support
+# compiling with MSVC, which won't understand cygwin style symlinks.
+cp ${srcdir}/src/$TARGETDIR/ffitarget.h include/ffitarget.h