summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Huddleston Sequoia <jeremyhu@macports.org>2018-07-20 09:37:43 -0700
committerJeremy Huddleston Sequoia <jeremyhu@apple.com>2018-07-21 14:36:10 -0700
commitba73a671cb49f8e2c4417723a9dc233e328926ae (patch)
treedd271c812d6c778d40d07603626c9f7165dbe8c2 /configure.ac
parent65da63abc843fe448aaa86015d094cf016f325ba (diff)
downloadlibffi-ba73a671cb49f8e2c4417723a9dc233e328926ae.tar.gz
Update FFI_HIDDEN() to use .private_extern on Apple platforms and use the macro where appropriate
Fix issue #439 Signed-off-by: Jeremy Huddleston Sequoia <jeremyhu@macports.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aec2f55..27676b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -292,7 +292,11 @@ AM_CONDITIONAL(BUILD_DOCS, [test x$enable_docs = xyes])
AH_BOTTOM([
#ifdef HAVE_HIDDEN_VISIBILITY_ATTRIBUTE
#ifdef LIBFFI_ASM
+#ifdef __APPLE__
+#define FFI_HIDDEN(name) .private_extern name
+#else
#define FFI_HIDDEN(name) .hidden name
+#endif
#else
#define FFI_HIDDEN __attribute__ ((visibility ("hidden")))
#endif