summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAnthony Green <green@moxielogic.com>2022-09-12 08:53:06 -0400
committerAnthony Green <green@moxielogic.com>2022-09-12 08:53:06 -0400
commita1130f37712c03957c9b0adf316cd006fa92a60b (patch)
tree8569aebb6248f6c469de49776a5061f67e4e059b /configure.ac
parent26cc9a6c73c80e8459c25da3718c91cf5a36cbd8 (diff)
downloadlibffi-a1130f37712c03957c9b0adf316cd006fa92a60b.tar.gz
Add static trampoline support for Cygwin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8edb7b6..75cc455 100644
--- a/configure.ac
+++ b/configure.ac
@@ -392,6 +392,12 @@ AC_ARG_ENABLE(exec-static-tramp,
if test "$enable_exec_static_tramp" != no; then
case "$target" in
*-cygwin*)
+ # Only define static trampolines if we are using the cygwin runtime.
+ # Will this need to be changed for mingw?
+ if test "x$GCC" = "xyes"; then
+ AC_DEFINE(FFI_EXEC_STATIC_TRAMP, 1,
+ [Define this if you want statically defined trampolines])
+ fi
;;
*arm*-*-linux-* | aarch64*-*-linux-* | i*86-*-linux-* | x86_64-*-linux-* | loongarch*-*-linux-*)
AC_DEFINE(FFI_EXEC_STATIC_TRAMP, 1,