summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorClément Chigot <pro@helflym.eu>2022-09-01 14:47:16 +0200
committerGitHub <noreply@github.com>2022-09-01 08:47:16 -0400
commit80912f2f09f4c06b2f720ff243d7b9b6795093f9 (patch)
tree20e33bbbe1553bae46c04219755b9996af960f81 /configure.ac
parent1fa7d96cdf7bba354f61337854210f060ea56b9f (diff)
downloadlibffi-80912f2f09f4c06b2f720ff243d7b9b6795093f9.tar.gz
Makefile: enable target overridings. (#661)
This patch allows target to provide extra files enabling the override of Makefile rules. This patch is not needed for libffi itself but only for GCC on AIX. The t-aix file which is here empty will be replaced in GCC repository. We cannot include GCC version directly here because it has no sense for a standalone libffi. Co-authored-by: Clement <clement.chigot@atos.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7a17a23..915b820 100644
--- a/configure.ac
+++ b/configure.ac
@@ -431,6 +431,16 @@ else
fi
AC_SUBST(toolexeclibdir)
+# Conditionalize the makefile for this target machine.
+tmake_file_=
+for f in ${tmake_file}; do
+ if test -f ${srcdir}/src/$TARGETDIR/$f; then
+ tmake_file_="${tmake_file_} \$(srcdir)/src/$TARGETDIR/$f"
+ fi
+done
+tmake_file="${tmake_file_}"
+AC_SUBST(tmake_file)
+
# Check linker support.
LIBFFI_ENABLE_SYMVERS