summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAnthony Green <green@moxielogic.com>2013-01-10 07:25:10 -0500
committerAnthony Green <green@moxielogic.com>2013-01-10 07:25:10 -0500
commit56ba8d86f47937a0afb81a2b9e77c9d235d9db45 (patch)
tree8044a926461c3588109bcf97d987fd174e108937 /configure.ac
parent6a028caec1b2c7904feb4c4f9cb7e1125e1d1b60 (diff)
downloadlibffi-56ba8d86f47937a0afb81a2b9e77c9d235d9db45.tar.gz
Don't use warning checking macro with sun compiler
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 13d5bc2..ac380bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,8 +36,14 @@ AM_PROG_CC_C_O
AC_PROG_LIBTOOL
AC_CONFIG_MACRO_DIR([m4])
+AX_COMPILER_VENDOR
AX_CC_MAXOPT
-AX_CFLAGS_WARN_ALL
+# The AX_CFLAGS_WARN_ALL macro doesn't currently work for sunpro
+# compiler.
+if test "$ax_cv_c_compiler_vendor" != "sun"; then
+ AX_CFLAGS_WARN_ALL
+fi
+
if test "x$GCC" = "xyes"; then
CFLAGS="$CFLAGS -fexceptions"
touch local.exp