summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYavor Georgiev <fealebenpae@gmail.com>2015-01-16 15:19:38 +0200
committerYavor Georgiev <fealebenpae@gmail.com>2015-01-16 15:31:55 +0200
commit536366349ced9d57c873d64e219ba30992a83c06 (patch)
tree91b5458b0c739c139d51ce57eaba73f393f61030 /configure.ac
parent05e65b4e2064f24669e8cc1c1cece1cbb0577548 (diff)
downloadlibffi-536366349ced9d57c873d64e219ba30992a83c06.tar.gz
aarch64: implement the trampoline table workaround for ffi closures on Apple systems
This is a direct copy/paste port of the ARM code, with changes because of Aarch64 pc-relative addressing restrictions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4754c03..467e311 100644
--- a/configure.ac
+++ b/configure.ac
@@ -215,7 +215,7 @@ fi
FFI_EXEC_TRAMPOLINE_TABLE=0
case "$target" in
- *arm*-apple-darwin*)
+ *arm*-apple-darwin* | aarch64-apple-darwin*)
FFI_EXEC_TRAMPOLINE_TABLE=1
AC_DEFINE(FFI_EXEC_TRAMPOLINE_TABLE, 1,
[Cannot use PROT_EXEC on this target, so, we revert to