summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMoritz Angermann <moritz.angermann@gmail.com>2017-05-16 08:32:06 +0800
committerMoritz Angermann <moritz.angermann@gmail.com>2017-05-16 08:58:11 +0800
commit19ab448d84223d2992048bce4e926eac2c44f606 (patch)
tree7c2019ecac174f56700efc34e7ff3934770d6273 /configure.ac
parentc0cc9f1df9fd4c5e758470f05d0e48123f0638ae (diff)
downloadlibffi-19ab448d84223d2992048bce4e926eac2c44f606.tar.gz
Support -ios triple
Autoconf hasn’t had an update since 2014, and it doesn’t look like it will soon[1] This updates config.{guess,sub} It adds support for e.g. `-ios`, which allows to have targets like `aarch64-apple-ios`. It basically does exactly what the config.guess script says: > It is advised that you download the most up to date version of the config scripts from The configure.ac script has been updated to relax `*-apple-darwin*` to `*-apple-*`. Similarly the `.gitignore` and `autogen.sh` needed to be updated to respect the newer `config.{sub,guess}` — [1]: http://lists.gnu.org/archive/html/autoconf/2016-07/msg00017.html
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e49a788..a10473d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -191,13 +191,13 @@ fi
FFI_EXEC_TRAMPOLINE_TABLE=0
case "$target" in
- *arm*-apple-darwin* | aarch64-apple-darwin*)
+ *arm*-apple-* | aarch64-apple-*)
FFI_EXEC_TRAMPOLINE_TABLE=1
AC_DEFINE(FFI_EXEC_TRAMPOLINE_TABLE, 1,
[Cannot use PROT_EXEC on this target, so, we revert to
alternative means])
;;
- *-apple-darwin* | *-*-freebsd* | *-*-kfreebsd* | *-*-openbsd* | *-pc-solaris*)
+ *-apple-* | *-*-freebsd* | *-*-kfreebsd* | *-*-openbsd* | *-pc-solaris*)
AC_DEFINE(FFI_MMAP_EXEC_WRIT, 1,
[Cannot use malloc on this target, so, we revert to
alternative means])