summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorzhangwenlong <zhangwenlong@loongson.cn>2022-05-25 09:31:08 +0800
committerGitHub <noreply@github.com>2022-05-24 21:31:08 -0400
commitf259a6f6deff9bdc7dd998b8b6bdbb4c166b33c3 (patch)
tree262f682b490247341e00391f0c9481a03d4894a5 /Makefile.am
parentd02d46607b5ba62510ddab5fa89303dfa09a7853 (diff)
downloadlibffi-f259a6f6deff9bdc7dd998b8b6bdbb4c166b33c3.tar.gz
Support loongarch64 (#678)
* update config.{guess,sub} * Support loongarch64 Co-Authored-By: Cheng Lulu <chenglulu@loongson.cn> Co-Authored-By: Xi Ruoyao <xry111@mengyan1223.wang> Co-Authored-By: Xu Hao Co-Authored-By: Zhang Wenlong <zhangwenlong@loongson.cn> Co-Authored-By: Pan Xuefeng <panxuefeng@loongson.cn> Co-authored-by: panxuefeng <panxuefeng@loongson.cn> Co-authored-by: Cheng Lulu <chenglulu@loongson.cn> Co-authored-by: Xi Ruoyao <xry111@mengyan1223.wang>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index dc8283f..a1a8912 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -63,7 +63,8 @@ noinst_HEADERS = src/aarch64/ffitarget.h src/aarch64/internal.h \
src/sparc/internal.h src/tile/ffitarget.h src/vax/ffitarget.h \
src/x86/ffitarget.h src/x86/internal.h src/x86/internal64.h \
src/x86/asmnames.h src/xtensa/ffitarget.h src/dlmalloc.c \
- src/kvx/ffitarget.h src/kvx/asm.h
+ src/kvx/ffitarget.h src/kvx/asm.h \
+ src/loongarch64/ffitarget.h
EXTRA_libffi_la_SOURCES = src/aarch64/ffi.c src/aarch64/sysv.S \
src/aarch64/win64_armasm.S src/alpha/ffi.c src/alpha/osf.S \
@@ -93,7 +94,7 @@ EXTRA_libffi_la_SOURCES = src/aarch64/ffi.c src/aarch64/sysv.S \
src/x86/ffiw64.c src/x86/win64.S src/x86/ffi64.c \
src/x86/unix64.S src/x86/sysv_intel.S src/x86/win64_intel.S \
src/xtensa/ffi.c src/xtensa/sysv.S src/kvx/ffi.c \
- src/kvx/sysv.S
+ src/kvx/sysv.S src/loongarch64/ffi.c src/loongarch64/sysv.S
TARGET_OBJ = @TARGET_OBJ@
libffi_la_LIBADD = $(TARGET_OBJ)