summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJosh Triplett <josh@joshtriplett.org>2014-03-16 03:25:53 -0700
committerJosh Triplett <josh@joshtriplett.org>2014-03-16 05:05:06 -0700
commite1911f78df113ca58738b66089a070d4cf747de7 (patch)
treef27856d28c9a252629c8a57387aecefd4e919bc8 /Makefile.am
parent9531d05f64c2a674e0197158ffad68d69f177bd0 (diff)
downloadlibffi-e1911f78df113ca58738b66089a070d4cf747de7.tar.gz
Add support for stdcall, thiscall, and fastcall on non-Windows x86-32
Linux supports the stdcall calling convention, either via functions explicitly declared with the stdcall attribute, or via code compiled with -mrtd which effectively makes stdcall the default. This introduces FFI_STDCALL, FFI_THISCALL, and FFI_FASTCALL on non-Windows x86-32 platforms, as non-default calling conventions.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index be11558..25e2121 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -125,7 +125,7 @@ if BFIN
nodist_libffi_la_SOURCES += src/bfin/ffi.c src/bfin/sysv.S
endif
if X86
-nodist_libffi_la_SOURCES += src/x86/ffi.c src/x86/sysv.S
+nodist_libffi_la_SOURCES += src/x86/ffi.c src/x86/sysv.S src/x86/win32.S
endif
if X86_FREEBSD
nodist_libffi_la_SOURCES += src/x86/ffi.c src/x86/freebsd.S