summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAnthony Green <green@moxielogic.com>2014-02-28 17:20:59 -0500
committerAnthony Green <green@moxielogic.com>2014-02-28 17:20:59 -0500
commita04e30ba3dc303133d459c1ac273ceefe4d49b32 (patch)
treee608aac26b02972d1d7359eec3b3245e89551999 /Makefile.am
parent934dc1b5c8d6a9e727bedc72342831eb7d62c35f (diff)
downloadlibffi-a04e30ba3dc303133d459c1ac273ceefe4d49b32.tar.gz
Add missing -DFFI_DEBUG flag
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d25aebd..0791e00 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -236,6 +236,13 @@ nodist_libffi_convenience_la_SOURCES = $(nodist_libffi_la_SOURCES)
LTLDFLAGS = $(shell $(SHELL) $(top_srcdir)/libtool-ldflags $(LDFLAGS))
+AM_CFLAGS =
+if FFI_DEBUG
+# Build debug. Define FFI_DEBUG on the commandline so that, when building with
+# MSVC, it can link against the debug CRT.
+AM_CFLAGS += -DFFI_DEBUG
+endif
+
libffi_la_LDFLAGS = -no-undefined -version-info `grep -v '^\#' $(srcdir)/libtool-version` $(LTLDFLAGS) $(AM_LTLDFLAGS)
AM_CPPFLAGS = -I. -I$(top_srcdir)/include -Iinclude -I$(top_srcdir)/src