summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAnthony Green <green@moxielogic.com>2019-11-22 12:42:26 -0500
committerAnthony Green <green@moxielogic.com>2019-11-22 12:42:26 -0500
commit8e3935fa761d3e6f19ccf5e6733fd40dee637d94 (patch)
tree3fb849995c6f9cf528168734bde2de10220f3d4f /Makefile.am
parentd01088a5194ff1a2250e7dbee04a9a167b582db7 (diff)
downloadlibffi-8e3935fa761d3e6f19ccf5e6733fd40dee637d94.tar.gz
Manual clean-ups, and include the PDF in the source distribution.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d1381fd..4fd6193 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,7 +21,7 @@ EXTRA_DIST = LICENSE ChangeLog.old \
generate-darwin-source-and-headers.py \
libffi.xcodeproj/project.pbxproj \
libtool-ldflags libtool-version configure.host README.md \
- libffi.map.in LICENSE-BUILDTOOLS msvc_build make_sunver.pl
+ libffi.map.in LICENSE-BUILDTOOLS msvc_build make_sunver.pl
# local.exp is generated by configure
DISTCLEANFILES = local.exp
@@ -153,5 +153,7 @@ AM_CPPFLAGS = -I. -I$(top_srcdir)/include -Iinclude -I$(top_srcdir)/src
AM_CCASFLAGS = $(AM_CPPFLAGS)
dist-hook:
+ d=`(cd $(distdir); pwd)`; (cd doc; make pdf; cp *.pdf $$d/doc)
if [ -d $(top_srcdir)/.git ] ; then (cd $(top_srcdir); git log --no-decorate) ; else echo 'See git log for history.' ; fi > $(distdir)/ChangeLog
s=`awk '/was released on/{ print NR; exit}' $(top_srcdir)/README.md`; tail -n +$$(($$s-1)) $(top_srcdir)/README.md > $(distdir)/README.md
+