summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorClément Chigot <pro@helflym.eu>2022-09-01 14:47:16 +0200
committerGitHub <noreply@github.com>2022-09-01 08:47:16 -0400
commit80912f2f09f4c06b2f720ff243d7b9b6795093f9 (patch)
tree20e33bbbe1553bae46c04219755b9996af960f81 /Makefile.am
parent1fa7d96cdf7bba354f61337854210f060ea56b9f (diff)
downloadlibffi-80912f2f09f4c06b2f720ff243d7b9b6795093f9.tar.gz
Makefile: enable target overridings. (#661)
This patch allows target to provide extra files enabling the override of Makefile rules. This patch is not needed for libffi itself but only for GCC on AIX. The t-aix file which is here empty will be replaced in GCC repository. We cannot include GCC version directly here because it has no sense for a standalone libffi. Co-authored-by: Clement <clement.chigot@atos.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a1a8912..31ece7b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -150,3 +150,5 @@ dist-hook:
if [ -d $(top_srcdir)/.git ] ; then (cd $(top_srcdir); git log --no-decorate) ; else echo 'See git log for history.' ; fi > $(distdir)/ChangeLog
s=`awk '/was released on/{ print NR; exit}' $(top_srcdir)/README.md`; tail -n +$$(($$s-1)) $(top_srcdir)/README.md > $(distdir)/README.md
+# target overrides
+-include $(tmake_file)