summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTom Tromey <tom@tromey.com>2016-02-22 15:34:39 -0700
committerTom Tromey <tom@tromey.com>2016-02-22 15:49:43 -0700
commit6dd5fd5a643c50aff3303ba2add3b6cc7588df78 (patch)
treece7a3e3d5998c7e801507514937c21b2dafd5b77 /Makefile.am
parentf2f234aef203a5e836b83cb772f9473f7ea0d5ce (diff)
downloadlibffi-6dd5fd5a643c50aff3303ba2add3b6cc7588df78.tar.gz
fix documentation building
An earlier patch added --disable-docs, but went too far, making it impossible to build the docs. It turns out that Automake seemingly has a bug preventing the conditional build of an info file. So, this patch works around the bug by putting the info_TEXINFOS rule into a new doc/Makefile.am. Tested by building with and without --disable-docs and looking for the existence of doc/libffi.info.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 5712edd..20fa382 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,6 +5,14 @@ AUTOMAKE_OPTIONS = foreign subdir-objects
ACLOCAL_AMFLAGS = -I m4
SUBDIRS = include testsuite man
+if BUILD_DOCS
+## This hack is needed because it doesn't seem possible to make a
+## conditional info_TEXINFOS in Automake. At least Automake 1.14
+## either gives errors -- if this attempted in the most
+## straightforward way -- or simply unconditionally tries to build the
+## info file.
+SUBDIRS += doc
+endif
EXTRA_DIST = LICENSE ChangeLog.v1 ChangeLog.libgcj \
ChangeLog.libffi ChangeLog.libffi-3.1 \
@@ -16,11 +24,6 @@ EXTRA_DIST = LICENSE ChangeLog.v1 ChangeLog.libgcj \
libtool-ldflags
-info_TEXINFOS =
-if BUILD_DOCS
-#info_TEXINFOS += doc/libffi.texi
-endif
-
## ################################################################
##