summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorYann Sionneau <yann@sionneau.net>2020-05-01 13:59:11 +0200
committerGitHub <noreply@github.com>2020-05-01 07:59:11 -0400
commit5e6ca054148dfb4d78e6f79457d48b745f919def (patch)
tree6be5670d50ecea0e9931618e774a3394c7fc721d /Makefile.am
parent4f9e20ac51ce13d46fed3c869e1deb6d9bb89444 (diff)
downloadlibffi-5e6ca054148dfb4d78e6f79457d48b745f919def.tar.gz
Add support for Kalray KVX architecture (#559)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 563e9f2..0e66ee9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -74,7 +74,8 @@ noinst_HEADERS = \
src/vax/ffitarget.h \
src/x86/ffitarget.h src/x86/internal.h src/x86/internal64.h src/x86/asmnames.h \
src/xtensa/ffitarget.h \
- src/dlmalloc.c
+ src/dlmalloc.c \
+ src/kvx/ffitarget.h
EXTRA_libffi_la_SOURCES = src/aarch64/ffi.c src/aarch64/sysv.S \
src/aarch64/win64_armasm.S src/alpha/ffi.c src/alpha/osf.S \
@@ -102,7 +103,8 @@ EXTRA_libffi_la_SOURCES = src/aarch64/ffi.c src/aarch64/sysv.S \
src/vax/ffi.c src/vax/elfbsd.S src/x86/ffi.c src/x86/sysv.S \
src/x86/ffiw64.c src/x86/win64.S src/x86/ffi64.c \
src/x86/unix64.S src/x86/sysv_intel.S src/x86/win64_intel.S \
- src/xtensa/ffi.c src/xtensa/sysv.S
+ src/xtensa/ffi.c src/xtensa/sysv.S \
+ src/kvx/ffi.c src/kvx/sysv.S
TARGET_OBJ = @TARGET_OBJ@
libffi_la_LIBADD = $(TARGET_OBJ)