summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am28
1 files changed, 17 insertions, 11 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 6bcf27c..7c4b98e 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,23 +1,29 @@
-AM_CFLAGS =-DFAKE_SLEEP -DFAKE_INTERNAL_CALLS -I../ -I../src
+AM_CPPFLAGS =-DFAKE_SLEEP -DFAKE_INTERNAL_CALLS -I@top_srcdir@/src
+AM_CFLAGS =
AM_LDFLAGS =
-bin_PROGRAMS = timetest
+# functests.sh fail for me, test.sh hangs for me.
+# TESTS = test.sh functests.sh
+check_PROGRAMS = timetest
timetest_SOURCES = timetest.c
+check_SCRIPTS = functests.sh testframe.sh test.sh
+EXTRA_DIST = $(check_SCRIPTS) \
+ functests/common.inc \
+ functests/dont_test_false.sh \
+ functests/test_exclude_mono.sh \
+ functests/test_null.sh \
+ functests/test_true.sh \
+ functests/test_walkone.sh
if SOLARIS
- AM_CFLAGS += -D__EXTENSIONS__ -D_XOPEN_SOURCE=600
+ AM_CPPFLAGS += -D__EXTENSIONS__ -D_XOPEN_SOURCE=600
AM_LDFLAGS += -Wl,--version-script=libfaketime.map
endif
if !MACOS
- AM_CFLAGS += -std=gnu99 -Wall -Wextra -Werror -DFAKE_STAT -DFAKE_PTHREAD -DFAKE_TIMERS -DFAKE_INTERNAL_CALLS -fPIC -Wno-nonnull-compare
+ AM_CPPFLAGS += -DFAKE_STAT -DFAKE_PTHREAD -DFAKE_TIMERS -DFAKE_INTERNAL_CALLS
+ AM_CFLAGS += -std=gnu99 -Wall -Wextra -Werror -fPIC -Wno-nonnull-compare
timetest_LDADD = -ldl -lm -lrt -lpthread
endif
-test: timetest functest
- @echo
- @./test.sh
-#
-# run functional tests
-functest:
- ./testframe.sh functests
+