summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Seiderer <ps.report@gmx.net>2020-03-02 16:16:27 +0100
committerPeter Hutterer <peter.hutterer@who-t.net>2020-03-13 04:01:20 +0000
commitfe8238a71ae3ad8a776ee35a88fc292f1f006ec7 (patch)
tree317f19f0ea02ef225f76ccddbf621dfe2bea6c76 /meson.build
parenta1fe50635e397a0f8546681a3fd64e8fbf164d41 (diff)
downloadlibevdev-fe8238a71ae3ad8a776ee35a88fc292f1f006ec7.tar.gz
meson.build: use local include path for tools
Fixes the following compile failure with old toolchains and meson build (autotools build not affected): ../tools/mouse-dpi-tool.c: In function ‘handle_event’: ../tools/mouse-dpi-tool.c:115:13: error: ‘const struct input_event’ has no member named ‘input_event_sec’ m->us = ev->input_event_sec * 1000000 + ev->input_event_usec; ^ ../tools/mouse-dpi-tool.c:115:45: error: ‘const struct input_event’ has no member named ‘input_event_usec’ m->us = ev->input_event_sec * 1000000 + ev->input_event_usec; ^ Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1456f83..dfcabc5 100644
--- a/meson.build
+++ b/meson.build
@@ -102,18 +102,22 @@ install_man(manpage)
# tools
executable('libevdev-events',
sources: ['tools/libevdev-events.c'],
+ include_directories: [includes_include],
dependencies: dep_libevdev,
install: false)
executable('touchpad-edge-detector',
sources: ['tools/touchpad-edge-detector.c'],
+ include_directories: [includes_include],
dependencies: [dep_libevdev, dep_lm],
install: true)
executable('mouse-dpi-tool',
sources: ['tools/mouse-dpi-tool.c'],
+ include_directories: [includes_include],
dependencies: dep_libevdev,
install: true)
executable('libevdev-tweak-device',
sources: ['tools/libevdev-tweak-device.c'],
+ include_directories: [includes_include],
dependencies: dep_libevdev,
install: true)