summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
new file mode 100644
index 0000000..8c49d04
--- /dev/null
+++ b/tests/meson.build
@@ -0,0 +1,9 @@
+libtest_utils = static_library('test-utils', 'cr-test-utils.c',
+ dependencies: libcroco_dep)
+
+foreach i : [0, 1, 2, 3, 4, 5, 6]
+ name = 'test@0@-main'.format(i)
+ test(name, executable(name, name + '.c',
+ link_with: libtest_utils,
+ dependencies: libcroco_dep))
+endforeach