summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristos Zoulas <christos@zoulas.com>2021-05-08 16:06:11 -0400
committerChristos Zoulas <christos@zoulas.com>2021-05-08 16:06:11 -0400
commitc4970dcd9de656a9cd351b97f74e6dd7f8a6a22c (patch)
treec5a38317250d52e3a22a80f6e9ea584abc2d90bf /configure.ac
parent38801ec390971d0e1d1a005209f63b02106e073d (diff)
downloadlibarchive-c4970dcd9de656a9cd351b97f74e6dd7f8a6a22c.tar.gz
NetBSD provides a statfs symbol for binary compatibility but does not
provide a visible struct statfs. Check for that.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 201185df..2c3838ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -685,6 +685,13 @@ AC_CHECK_TYPES(struct xvfsconf,,,
#include <sys/mount.h>
])
+AC_CHECK_TYPES(struct statfs,,,
+ [#if HAVE_SYS_TYPES_H
+ #include <sys/types.h>
+ #endif
+ #include <sys/mount.h>
+ ])
+
# There are several variants of readdir_r around; we only
# accept the POSIX-compliant version.
AC_COMPILE_IFELSE(