summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Matuska <martin@matuska.org>2016-11-23 17:52:03 +0100
committerMartin Matuska <martin@matuska.org>2016-11-23 17:52:03 +0100
commit992652f4387caa62ac252dc51647a267ca9c579a (patch)
tree83f8aa95dd8fe7c102f7efaaed301a45071af2a4 /configure.ac
parent4bcbb1b0911936feb3299ae3b8242b61908c6102 (diff)
downloadlibarchive-992652f4387caa62ac252dc51647a267ca9c579a.tar.gz
Add missing check for acl_is_trivial_np() to configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d4e5aac5..86f87e07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -703,7 +703,8 @@ if test "x$enable_acl" != "xno"; then
# (It's a pretty obvious oversight; otherwise, there's no way to
# test for specific permissions in a permset.) Linux uses the obvious
# name, FreeBSD adds _np to mark it as "non-Posix extension."
- # Test for both as a double-check that we really have POSIX-style ACL support.
+ # Test for both as a double-check that we really have POSIX-style ACL
+ # support.
AC_CHECK_FUNCS(acl_get_perm_np acl_get_perm acl_get_link acl_get_link_np,,,
[#if HAVE_SYS_TYPES_H
#include <sys/types.h>
@@ -713,6 +714,16 @@ if test "x$enable_acl" != "xno"; then
#endif
])
+ # Check for acl_is_trivial_np on FreeBSD
+ AC_CHECK_FUNCS(acl_is_trivial_np,,,
+ [#if HAVE_SYS_TYPES_H
+ #include <sys/types.h>
+ #endif
+ #if HAVE_SYS_ACL_H
+ #include <sys/acl.h>
+ #endif
+ ])
+
# MacOS has an acl.h that isn't POSIX. It can be detected by
# checking for ACL_USER
AC_CHECK_DECL([ACL_USER],