summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Matuska <martin@matuska.org>2017-01-17 15:04:43 +0100
committerMartin Matuska <martin@matuska.org>2017-01-17 15:04:43 +0100
commit77ab581c3ec641fd7d3a504aeeabeb2aa829646b (patch)
tree7c03bf69abf968b21b148a79d7393d8f045d4536 /configure.ac
parentf8e2a7b40d6dbf15f03f0c1952cc370feceec91b (diff)
downloadlibarchive-77ab581c3ec641fd7d3a504aeeabeb2aa829646b.tar.gz
Use HAVE_ACL_TYPE_NFS4 instead of checking against system constant
Verify ACL types in test_acl_platform_nfs4.c Add missing inheritance flag to test_acl_platform_nfs4.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f97ef854..a2bce2cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -724,6 +724,12 @@ if test "x$enable_acl" != "xno"; then
#endif
])
+ # Check for ACL_TYPE_NFS4
+ AC_CHECK_DECL([ACL_TYPE_NFS4],
+ [AC_DEFINE(HAVE_ACL_TYPE_NFS4, 1, [True for FreeBSD with NFSv4 ACL support])],
+ [],
+ [#include <sys/acl.h>])
+
# MacOS has an acl.h that isn't POSIX. It can be detected by
# checking for ACL_USER
AC_CHECK_DECL([ACL_USER],