summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Matuska <martin@matuska.org>2017-01-30 01:39:03 +0100
committerMartin Matuska <martin@matuska.org>2017-01-30 03:09:43 +0100
commit6a509898d71ad4b31e4e4a00f42f7e8b00b7f03a (patch)
treecb293dfd0d3e4e915750b1acfced2fd4cd6eccb7 /configure.ac
parent0c488838d9f01a9a18a284170abe511b84aa5d4c (diff)
downloadlibarchive-6a509898d71ad4b31e4e4a00f42f7e8b00b7f03a.tar.gz
Disable automatic detection of liblzo2
Replace liblzo with lzop in Travis CI builds Fix lzop tests Distribution of libarchive binaries linked against LZO violates LZO GPL license. liblzo2 can still be linked with --with-lzo2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0afb59ce..f3b8fda4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -379,9 +379,9 @@ if test "x$with_lzma" != "xno"; then
fi
AC_ARG_WITH([lzo2],
- AS_HELP_STRING([--without-lzo2], [Don't build support for lzop through liblzo2]))
+ AS_HELP_STRING([--with-lzo2], [Build with LZO support from liblzo2]))
-if test "x$with_lzo2" != "xno"; then
+if test "x$with_lzo2" == "xyes"; then
AC_CHECK_HEADERS([lzo/lzoconf.h lzo/lzo1x.h])
AC_CHECK_LIB(lzo2,lzo1x_decompress_safe)
fi