summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Kientzle <kientzle@acm.org>2017-08-12 23:05:31 -0700
committerGitHub <noreply@github.com>2017-08-12 23:05:31 -0700
commit19f4e1eb5a29627195b3b6e0574ffdfd10cf1c7a (patch)
tree8a13c570893cea76115b70eb1a93e9de32ef3cde /configure.ac
parentd1a397680e5ae8ee50fe33e4add599fbaed3d739 (diff)
parent8bc18e0e8eadc83685c7407b29768ee96f26b227 (diff)
downloadlibarchive-19f4e1eb5a29627195b3b6e0574ffdfd10cf1c7a.tar.gz
Merge pull request #905 from iburinoc/zstd
Add support for Zstandard read and write filters
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a8b41831..e2266d65 100644
--- a/configure.ac
+++ b/configure.ac
@@ -367,6 +367,14 @@ if test "x$with_lz4" != "xno"; then
AC_CHECK_LIB(lz4,LZ4_decompress_safe)
fi
+AC_ARG_WITH([zstd],
+ AS_HELP_STRING([--without-zstd], [Don't build support for zstd through libzstd]))
+
+if test "x$with_zstd" != "xno"; then
+ AC_CHECK_HEADERS([zstd.h])
+ AC_CHECK_LIB(zstd,ZSTD_compressStream)
+fi
+
AC_ARG_WITH([lzma],
AS_HELP_STRING([--without-lzma], [Don't build support for xz through lzma]))