summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndres Mejia <amejia004@gmail.com>2013-02-22 21:40:33 -0500
committerAndres Mejia <amejia004@gmail.com>2013-02-22 21:44:17 -0500
commit014de9caa8326dadeb2b34c89de573af42d841a8 (patch)
tree6b3b66984a8d906e90cbe1f42f2a83b05a846c80 /configure.ac
parent94031e4b1f066cccf17a99596db1d0bb54395e99 (diff)
downloadlibarchive-014de9caa8326dadeb2b34c89de573af42d841a8.tar.gz
Revert "Allow adding extra CFLAGS with a configure option."
This reverts commit 64b3cefbdbc0d6deef1dd3bcde890e273c323168. Apparently, setting CFLAGS won't override the preset AM_CFLAGS afterall. Not sure why this was giving me a problem before.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 0 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 8a4afd75..73944d3e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -190,12 +190,6 @@ esac
AM_CONDITIONAL([BUILD_BSDCPIO], [ test "$build_bsdcpio" = yes ])
AM_CONDITIONAL([STATIC_BSDCPIO], [ test "$static_bsdcpio" = yes ])
-AC_ARG_WITH([extra-cflags],
- [AS_HELP_STRING([--with-extra-cflags=CFLAGS], [use extra CFLAGS])],
- [], [enable_extra_cflags= ])
-
-EXTRA_CFLAGS=$with_extra_cflags
-
# Set up defines needed before including any headers
case $host in
*mingw* | *cygwin* )
@@ -791,5 +785,4 @@ case "$host_os" in
;;
esac
-AC_SUBST(EXTRA_CFLAGS)
AC_OUTPUT