summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRose <83477269+AtariDreams@users.noreply.github.com>2023-01-09 09:18:30 -0500
committerGitHub <noreply@github.com>2023-01-09 15:18:30 +0100
commit013aef1275899bcee0b394402673a949c33c72db (patch)
tree66ab332e791f42e7a838f3d817af374b2991d4ba /configure.ac
parent0348e24bab24cc46642d29e3ceab64df22553298 (diff)
downloadlibarchive-013aef1275899bcee0b394402673a949c33c72db.tar.gz
Update autotools and fix warnings (#1815)
We do not need to check TIME_WITH_SYS_TIME anymore. We can check HAVE_SYS_TIME_H and not bother checking for C99.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f078f2cf..4f83fed2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,7 +12,7 @@ m4_define([BSDTAR_VERSION_S],LIBARCHIVE_VERSION_S())
m4_define([BSDCPIO_VERSION_S],LIBARCHIVE_VERSION_S())
m4_define([BSDCAT_VERSION_S],LIBARCHIVE_VERSION_S())
-AC_PREREQ([2.69])
+AC_PREREQ([2.71])
#
# Now starts the "real" configure script.
@@ -105,7 +105,6 @@ AC_SUBST(PLATFORMCPPFLAGS)
# Checks for programs.
AC_PROG_CC
-AC_PROG_CC_C99
AM_PROG_CC_C_O
AC_PROG_CPP
AC_USE_SYSTEM_EXTENSIONS
@@ -657,7 +656,7 @@ AC_CHECK_TYPE([wchar_t],
AX_COMPILE_CHECK_SIZEOF(int)
AX_COMPILE_CHECK_SIZEOF(long)
-AC_HEADER_TIME
+AC_CHECK_HEADERS_ONCE([sys/time.h])
# Checks for library functions.
AC_PROG_GCC_TRADITIONAL