summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Matuska <martin@matuska.org>2021-08-20 01:50:27 +0200
committerMartin Matuska <martin@matuska.org>2021-08-22 06:13:54 +0200
commitb41daecb5ccb4c8e3b2c53fd6147109fc12c3043 (patch)
tree19b83c6eef81492f624015970621dfc936e32c90 /Makefile.am
parente2ad1a2c3064fa9eba6274b3641c4c1beed25c0b (diff)
downloadlibarchive-b41daecb5ccb4c8e3b2c53fd6147109fc12c3043.tar.gz
Do not follow symlinks when processing the fixup list
Use lchmod() instead of chmod() and tell the remaining functions that the real file to be modified is a symbolic link. Fixes #1566
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 58edb74e..c93a82e9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -560,6 +560,7 @@ libarchive_test_SOURCES= \
libarchive/test/test_write_disk.c \
libarchive/test/test_write_disk_appledouble.c \
libarchive/test/test_write_disk_failures.c \
+ libarchive/test/test_write_disk_fixup.c \
libarchive/test/test_write_disk_hardlink.c \
libarchive/test/test_write_disk_hfs_compression.c \
libarchive/test/test_write_disk_lookup.c \