summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTomasz Mikolajewski <mtomasz@chromium.org>2014-11-10 16:29:53 +0900
committerMike Frysinger <vapier@gentoo.org>2019-04-26 09:34:42 +1000
commit6c55c379b18cdb448a92f9509847f0820352f857 (patch)
tree9ae242a955e45a36997d3135e4fe17e275b7afdc /Makefile.am
parentf563a55a4429ac043683bc64b407d55276d0dc13 (diff)
downloadlibarchive-6c55c379b18cdb448a92f9509847f0820352f857.tar.gz
zip: add support for Info-ZIP Unicode Path Extra Field
The zip specification supports storing path names in UTF-8 encoding via the Info-ZIP Unicode Path Extra Field (0x7075).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b7a2a6bc..bb887b7d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -512,6 +512,7 @@ libarchive_test_SOURCES= \
libarchive/test/test_read_format_warc.c \
libarchive/test/test_read_format_xar.c \
libarchive/test/test_read_format_zip.c \
+ libarchive/test/test_read_format_zip_7075_utf8_paths.c \
libarchive/test/test_read_format_zip_comment_stored.c \
libarchive/test/test_read_format_zip_encryption_data.c \
libarchive/test/test_read_format_zip_encryption_partially.c \
@@ -861,6 +862,7 @@ libarchive_test_EXTRA_DIST=\
libarchive/test/test_read_format_ustar_filename_koi8r.tar.Z.uu \
libarchive/test/test_read_format_warc.warc.uu \
libarchive/test/test_read_format_zip.zip.uu \
+ libarchive/test/test_read_format_zip_7075_utf8_paths.zip.uu \
libarchive/test/test_read_format_zip_bz2_hang.zip.uu \
libarchive/test/test_read_format_zip_bzip2.zipx.uu \
libarchive/test/test_read_format_zip_bzip2_multi.zipx.uu \