summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGrzegorz Antoniak <ga@anadoxin.org>2021-02-13 09:08:13 +0100
committerGrzegorz Antoniak <ga@anadoxin.org>2022-01-09 19:49:56 +0100
commit05ebb55896d10a9737dad9ae0303f7f45489ba6f (patch)
treede68e4d05c9153feaf570a9154e883070c3cc285 /Makefile.am
parent7ef089ec204a279ef87ebd19fbedef42ec418d05 (diff)
downloadlibarchive-05ebb55896d10a9737dad9ae0303f7f45489ba6f.tar.gz
RAR5 reader: fixed out of bounds read in some files
Added more range checks in the bit stream reading functions (read_bits_16 and read_bits_32) in order to better guard against out of memory reads. This commit contains a test with OSSFuzz sample #30448.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c5796f29..963c9421 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -893,6 +893,7 @@ libarchive_test_EXTRA_DIST=\
libarchive/test/test_read_format_rar5_arm_filter_on_window_boundary.rar.uu \
libarchive/test/test_read_format_rar5_different_winsize_on_merge.rar.uu \
libarchive/test/test_read_format_rar5_block_size_is_too_small.rar.uu \
+ libarchive/test/test_read_format_rar5_decode_number_out_of_bounds_read.rar.uu \
libarchive/test/test_read_format_raw.bufr.uu \
libarchive/test/test_read_format_raw.data.gz.uu \
libarchive/test/test_read_format_raw.data.Z.uu \