summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Matuska <martin@matuska.org>2019-05-26 01:48:39 +0200
committerMartin Matuska <martin@matuska.org>2019-05-26 08:18:49 +0200
commitb66555921c0457645be2f75aaa876d7cf12af5c6 (patch)
treef20b63a22b50acf91041658768c31de00cc88d70 /CMakeLists.txt
parentb837c72c423b744a2e6c554742877173406dbfa0 (diff)
downloadlibarchive-b66555921c0457645be2f75aaa876d7cf12af5c6.tar.gz
archive_write_disk_posix: check_symlinks_fsobj() without chdir()
only on platforms with openat(), fstatat() and unlinkat() support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0d6b8f14..f8f0c755 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1350,6 +1350,7 @@ CHECK_FUNCTION_EXISTS_GLIBC(strrchr HAVE_STRRCHR)
CHECK_FUNCTION_EXISTS_GLIBC(symlink HAVE_SYMLINK)
CHECK_FUNCTION_EXISTS_GLIBC(timegm HAVE_TIMEGM)
CHECK_FUNCTION_EXISTS_GLIBC(tzset HAVE_TZSET)
+CHECK_FUNCTION_EXISTS_GLIBC(unlinkat HAVE_TZSET)
CHECK_FUNCTION_EXISTS_GLIBC(unsetenv HAVE_UNSETENV)
CHECK_FUNCTION_EXISTS_GLIBC(utime HAVE_UTIME)
CHECK_FUNCTION_EXISTS_GLIBC(utimes HAVE_UTIMES)