summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Matuska <martin@matuska.org>2020-01-28 00:25:53 +0100
committerMartin Matuska <martin@matuska.org>2020-01-28 00:25:53 +0100
commit9ebb248419786e116b2533353c27ae6277cf1e7b (patch)
treecf270ee7156215881a3a2973bb6c139bb15bb4ca /CMakeLists.txt
parent09fe742bddfcd9cc3e80ea5d608097a21446a235 (diff)
downloadlibarchive-9ebb248419786e116b2533353c27ae6277cf1e7b.tar.gz
Cmake MSVC: replace warning C4061 with C4062
Fixes #1322
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9e46c6ca..7a9f3d19 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -155,9 +155,9 @@ IF (MSVC)
#################################################################
# Set compile flags for debug build.
# This is added into CMAKE_C_FLAGS when CMAKE_BUILD_TYPE is "Debug"
- # Enable level 4 C4061: The enumerate has no associated handler in a switch
- # statement.
- SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} /we4061")
+ # Enable level 4 C4062: The enumerate has no associated handler in a switch
+ # statement and there is no default that can catch it.
+ SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} /we4062")
# Enable level 4 C4254: A larger bit field was assigned to a smaller bit
# field.
SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} /we4254")