summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristos Zoulas <christos@zoulas.com>2021-05-08 16:07:51 -0400
committerChristos Zoulas <christos@zoulas.com>2021-05-08 16:07:51 -0400
commit682ba6b50a8ce290ce3091572a9f4eeb93245937 (patch)
tree56056b73638e02f2f17b4826eca65f501e99c4ed /CMakeLists.txt
parente597f8bfee283684e8f9bbdc7a835662d4551144 (diff)
downloadlibarchive-682ba6b50a8ce290ce3091572a9f4eeb93245937.tar.gz
Catch up with autoconf changes:
HAVE_STRUCT_STATFS HAVE_STRUCT_STATFS_F_IOSIZE
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9d8fc3c4..95537fe8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1421,6 +1421,10 @@ CHECK_C_SOURCE_COMPILES(
"#include <sys/types.h>\n#include <sys/mount.h>\nint main(void) { struct xvfsconf v; return sizeof(v);}"
HAVE_STRUCT_XVFSCONF)
+CHECK_C_SOURCE_COMPILES(
+ "#include <sys/types.h>\n#include <sys/mount.h>\nint main(void) { struct statfs s; return sizeof(s);}"
+ HAVE_STRUCT_STATFS)
+
# Make sure we have the POSIX version of readdir_r, not the
# older 2-argument version.
CHECK_C_SOURCE_COMPILES(
@@ -1496,9 +1500,14 @@ CHECK_STRUCT_HAS_MEMBER("struct tm" tm_gmtoff
CHECK_STRUCT_HAS_MEMBER("struct tm" __tm_gmtoff
"time.h" HAVE_STRUCT_TM___TM_GMTOFF)
+IF(HAVE_STRUCT_STATFS)
# Check for f_namemax in struct statfs
CHECK_STRUCT_HAS_MEMBER("struct statfs" f_namemax
"sys/param.h;sys/mount.h" HAVE_STRUCT_STATFS_F_NAMEMAX)
+# Check for f_iosize in struct statfs
+CHECK_STRUCT_HAS_MEMBER("struct statfs" f_iosize
+ "sys/param.h;sys/mount.h" HAVE_STRUCT_STATFS_F_IOSIZE)
+ENDIF(HAVE_STRUCT_STATFS)
# Check for birthtime in struct stat
CHECK_STRUCT_HAS_MEMBER("struct stat" st_birthtime