summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRose <83477269+AtariDreams@users.noreply.github.com>2023-01-09 09:18:30 -0500
committerGitHub <noreply@github.com>2023-01-09 15:18:30 +0100
commit013aef1275899bcee0b394402673a949c33c72db (patch)
tree66ab332e791f42e7a838f3d817af374b2991d4ba /CMakeLists.txt
parent0348e24bab24cc46642d29e3ceab64df22553298 (diff)
downloadlibarchive-013aef1275899bcee0b394402673a949c33c72db.tar.gz
Update autotools and fix warnings (#1815)
We do not need to check TIME_WITH_SYS_TIME anymore. We can check HAVE_SYS_TIME_H and not bother checking for C99.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f5fb821c..dbb95e34 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1560,7 +1560,7 @@ ENDIF()
#
#
CHECK_STRUCT_HAS_MEMBER("struct tm" tm_sec
- "sys/types.h;sys/time.h;time.h" TIME_WITH_SYS_TIME)
+ "sys/types.h;sys/time.h;time.h" HAVE_SYS_TIME_H)
#
# Check for integer types