summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorwrowe <wrowe@13f79535-47bb-0310-9956-ffa450edef68>2002-10-17 17:40:24 +0000
committerwrowe <wrowe@13f79535-47bb-0310-9956-ffa450edef68>2002-10-17 17:40:24 +0000
commitaeb529a1c72aaf6bdb676764b35d5b605a4020ca (patch)
treeef735a2b11c28edab6043838189733ab11c5cac2 /configure.in
parent0a3692ffc2b6d4a6a88984704842320a94313e79 (diff)
downloadlibapr-aeb529a1c72aaf6bdb676764b35d5b605a4020ca.tar.gz
Platform preference for shl_load on HPUX11 must be expressed by testing
first for that method. dlopen on HPUX11/64 bit OS'es or including one off libdld's should not be recognized. git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@63941 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 650b365df..dc4a349d4 100644
--- a/configure.in
+++ b/configure.in
@@ -1254,6 +1254,10 @@ AC_ARG_ENABLE(dso,
[
AC_CHECK_FUNCS(NSLinkModule, [ tempdso="dyld" ], [ tempdso="no" ])
if test "$tempdso" = "no"; then
+ AC_CHECK_LIB(dld, shl_load, [ tempdso="shl" APR_ADDTO(LIBS,-ldld) ],
+ tempdso="no")
+ fi
+ if test "$tempdso" = "no"; then
AC_CHECK_FUNCS(dlopen, [ tempdso="dlfcn" ], [ tempdso="no" ])
fi
if test "$tempdso" = "no"; then
@@ -1264,10 +1268,6 @@ AC_ARG_ENABLE(dso,
AC_CHECK_LIB(root, load_image, tempdso="yes", tempdso="no")
fi
if test "$tempdso" = "no"; then
- AC_CHECK_LIB(dld, shl_load, [ tempdso="shl" APR_ADDTO(LIBS,-ldld) ],
- tempdso="no")
- fi
- if test "$tempdso" = "no"; then
case $host in
*os390|*-os2*|*os400)
tempdso="yes"