summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorwrowe <wrowe@13f79535-47bb-0310-9956-ffa450edef68>2007-11-02 01:54:33 +0000
committerwrowe <wrowe@13f79535-47bb-0310-9956-ffa450edef68>2007-11-02 01:54:33 +0000
commit5c8435d6f35d6456881e1ee351303ecb22f5def8 (patch)
treed7bc968628d84abdde4005da2b90e7c2a0ae50a2 /configure.in
parent80945d030f12c724c2b79929199057210aec4299 (diff)
downloadlibapr-5c8435d6f35d6456881e1ee351303ecb22f5def8.tar.gz
On Darwin 9.0 the NSLoad... dyld API is deprecated; use dlopen.
On HPUX 64bit PA-RISC or IA64... shl_ API is deprecated; use dlopen. (Unless we can't in which case we'll jump on shl at the end.) git-svn-id: http://svn.apache.org/repos/asf/apr/apr/trunk@591191 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 26 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 531bebbe3..b6c47e8f2 100644
--- a/configure.in
+++ b/configure.in
@@ -1578,11 +1578,26 @@ AC_ARG_ENABLE(dso,
], [dsotype=any])
if test "$dsotype" = "any"; then
- # Darwin:
- AC_CHECK_FUNC(NSLinkModule, [dsotype=dyld])
if test "$dsotype" = "any"; then
- # Original HP-UX:
- AC_CHECK_LIB(dld, shl_load, [dsotype=shl; APR_ADDTO(LIBS,-ldld)])
+ case $host in
+ *darwin[0-8]\.*)
+ # Original Darwin, not for 9.0!:
+ AC_CHECK_FUNC(NSLinkModule, [dsotype=dyld]);;
+ *-hpux[1-9]\.*|*-hpux1[01]*)
+ # shl is specific to hpux(?), and is suboptimal for 64 bit builds,
+ # and most unlikely to be the choice of 12.x developers.
+ AC_CHECK_LIB(dld, shl_load, [have_shl=1])
+ if test "$ac_cv_sizeof_voidp$have_shl" = "41"; then
+ dsotype=shl; APR_ADDTO(LIBS,-ldld)
+ fi;;
+ *mingw*|*-os2*)
+ # several 'other's below probably belong up here. If they always
+ # use a platform implementation and shouldn't test the dlopen/dlfcn
+ # features, then bring them up here.
+ # But if they -should- optionally use dlfcn, and/or need the config
+ # detection of dlopen/dlsym, do not move them up.
+ dsotype=other ;;
+ esac
fi
# Normal POSIX:
if test "$dsotype" = "any"; then
@@ -1606,7 +1621,13 @@ if test "$dsotype" = "any"; then
# Everything else:
if test "$dsotype" = "any"; then
case $host in
- *os390|*-os2*|*os400|*-aix*|*mingw*) dsotype=other ;;
+ *os390|*os400|*-aix*)
+ # Some -aix5 will use dl, no hassles. Keep that pattern here.
+ dsotype=other ;;
+ *-hpux*)
+ if test "$have_shl" = "1"; then
+ dsotype=shl; APR_ADDTO(LIBS,-ldld)
+ fi;;
esac
fi
fi