summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorjim <jim@13f79535-47bb-0310-9956-ffa450edef68>2014-01-25 15:17:29 +0000
committerjim <jim@13f79535-47bb-0310-9956-ffa450edef68>2014-01-25 15:17:29 +0000
commit2fbf888db3f478eacca730820d6607069350730d (patch)
tree15b332416491bad2d9d81eb8d8a60d785b401cb8 /configure.in
parentbc4aeb61108dc0e1d06c690d9c840ae4cd89b124 (diff)
downloadlibapr-2fbf888db3f478eacca730820d6607069350730d.tar.gz
Merge r1561321 from trunk:
Maintain ordering but use OVERRIDE if enabled AND found Reviewed/backported by: jim git-svn-id: http://svn.apache.org/repos/asf/apr/apr/branches/1.5.x@1561322 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 79aaacb8c..2a37a30bd 100644
--- a/configure.in
+++ b/configure.in
@@ -1238,6 +1238,11 @@ APR_IFALLYES(header:sys/mman.h func:mmap func:munmap,
[havemmaptmp="1"
APR_DECIDE(USE_SHMEM_MMAP_TMP,
[Classical mmap() on temporary file])])
+APR_IFALLYES(header:sys/mman.h func:mmap func:munmap func:shm_open dnl
+ func:shm_unlink,
+ [havemmapshm="1"
+ APR_DECIDE(USE_SHMEM_MMAP_SHM,
+ [mmap() via POSIX.1 shm_open() on temporary file])])
APR_IFALLYES(header:sys/ipc.h header:sys/shm.h header:sys/file.h dnl
func:shmget func:shmat func:shmdt func:shmctl,
[haveshmget="1"
@@ -1254,11 +1259,9 @@ APR_IFALLYES(header:windows.h,
AC_ARG_ENABLE(posix-shm,
[ --enable-posix-shm Use POSIX shared memory (shm_open) if available],
[
-APR_IFALLYES(header:sys/mman.h func:mmap func:munmap func:shm_open dnl
- func:shm_unlink,
- [havemmapshm="1"
- APR_DECIDE(USE_SHMEM_MMAP_SHM,
- [mmap() via POSIX.1 shm_open() on temporary file])])
+if test "$havemmapshm" = "1"; then
+ APR_DECISION_OVERRIDE(USE_SHMEM_MMAP_SHM)
+fi
])
case $host in
*linux* )