summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authortrawick <trawick@13f79535-47bb-0310-9956-ffa450edef68>2013-10-12 16:17:43 +0000
committertrawick <trawick@13f79535-47bb-0310-9956-ffa450edef68>2013-10-12 16:17:43 +0000
commitd88246950cccffec8cfa4f1015a7853f6e8e24d7 (patch)
tree06eca07d32e24638485592ae8e277ed7db5e1a93 /CMakeLists.txt
parent6c3921a00a751a469ba03d7503d2f90702c84df9 (diff)
downloadlibapr-d88246950cccffec8cfa4f1015a7853f6e8e24d7.tar.gz
Merge r1531554 from trunk:
don't spend 10 minutes in testlockperf during make test/check on Windows git-svn-id: http://svn.apache.org/repos/asf/apr/apr/branches/1.5.x@1531556 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 29ff1841e..35a566505 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -362,7 +362,6 @@ IF(APR_BUILD_TESTAPR)
# Add tests for programs that run by themselves with no arguments.
SET(simple_tests
- testlockperf
testmutexscope
testucs
)
@@ -371,6 +370,9 @@ IF(APR_BUILD_TESTAPR)
ADD_TEST(NAME ${simple} COMMAND ${simple})
ENDFOREACH()
+ # testlockperf takes forever on Windows with default counter limit
+ ADD_TEST(NAME testlockperf COMMAND testlockperf -c 50000)
+
# sendfile runs multiple times with different parameters.
FOREACH(sendfile_mode blocking nonblocking timeout)
ADD_TEST(NAME sendfile-${sendfile_mode} COMMAND sendfile client ${sendfile_mode} startserver)