summaryrefslogtreecommitdiff
path: root/plugins/fast_float/src/Makefile.am
diff options
context:
space:
mode:
authorMarti Maria <marti.maria@littlecms.com>2020-05-25 19:44:47 +0200
committerMarti Maria <marti.maria@littlecms.com>2020-05-25 19:44:47 +0200
commitd881cc6791858f67e1bfd6fa306c2184a99f99e9 (patch)
treeb097bdc641d4e8bec80ecd070ef3c481c5258bd7 /plugins/fast_float/src/Makefile.am
parentf9e2e80ab45a91dc99a9ca8eee39aa1986900b64 (diff)
downloadlcms2-d881cc6791858f67e1bfd6fa306c2184a99f99e9.tar.gz
Merged SSE matrix-shaper optimizer
It makes small difference, but here you go! In my computer, matrix shaper runs times x 2.4 faster the core lcms2 without SSE is about times x 2
Diffstat (limited to 'plugins/fast_float/src/Makefile.am')
-rw-r--r--plugins/fast_float/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/plugins/fast_float/src/Makefile.am b/plugins/fast_float/src/Makefile.am
index 4244cf7..9b597f2 100644
--- a/plugins/fast_float/src/Makefile.am
+++ b/plugins/fast_float/src/Makefile.am
@@ -24,5 +24,5 @@ liblcms2_fast_float_la_LIBADD = $(LCMS_LIB_DEPLIBS) $(top_builddir)/src/liblcms2
liblcms2_fast_float_la_SOURCES = \
fast_float_15bits.c fast_float_15mats.c fast_float_curves.c fast_float_matsh.c fast_float_separate.c \
fast_float_sup.c fast_float_tethra.c fast_float_cmyk.c fast_float_internal.h \
- fast_8_curves.c fast_8_matsh.c fast_8_tethra.c
+ fast_8_curves.c fast_8_matsh.c fast_8_matsh_sse.c fast_8_tethra.c