summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorL. E. Segovia <amy@amyspark.me>2022-12-03 11:08:43 -0300
committerL. E. Segovia <amy@amyspark.me>2022-12-06 17:53:16 +0000
commit1d38cfdc0acf2799ed74a47c42f4b23343ee9be9 (patch)
treeee221462b5a4058da78d8c65bd4c80c4801270f0 /meson.build
parent7e643dc74a5b6f80b0dff3a114d5203201493402 (diff)
downloadlcms2-1d38cfdc0acf2799ed74a47c42f4b23343ee9be9.tar.gz
meson: Support building utils
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 1669e18..c9cd356 100644
--- a/meson.build
+++ b/meson.build
@@ -2,7 +2,7 @@ project(
'Little-CMS',
'c',
version: '2.14',
- meson_version: '>=0.48.0',
+ meson_version: '>=0.49.0',
)
version_components = meson.project_version().split('.')
@@ -51,6 +51,10 @@ elif cc.has_header_symbol('time.h', 'gmtime_s')
endif
endif
+jpeg_dep = dependency('libjpeg', required: get_option('jpeg'))
+
+tiff_dep = dependency('libtiff-4', required: get_option('tiff'))
+
if (
not cc.compiles(
'''
@@ -80,6 +84,7 @@ deps = [m_dep, threads_dep]
subdir('include')
subdir('src')
subdir('testbed')
+subdir('utils')
pkg = import('pkgconfig')
pkg.generate(liblcms2_lib)