summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTimo Lotterbach <timo.lotterbach@bmw-carit.de>2012-11-26 05:50:07 -0800
committerTimo Lotterbach <timo.lotterbach@bmw-carit.de>2013-01-14 00:34:15 -0800
commit4c54d7da5a29ed66e070558a447639b946f3344e (patch)
tree7bbb7cd0d9df6b1e35928e783d63aaabfd4a1272 /CMakeLists.txt
parent31bff2a12a7f01187ee7057091efcdd9df48ac10 (diff)
downloadlayer_management-4c54d7da5a29ed66e070558a447639b946f3344e.tar.gz
LayerManagerService: moved Systemd health monitor to health plugin
the systemd integration was moved to an optional plugins. this way LayerManagerService has no dependencies on systemd. health monitoring plugins implement the interface IHealthMonitor. Currently there's only one avialable that uses systemd watchdog to report health status to the system. Signed-off-by: Timo Lotterbach <timo.lotterbach@bmw-carit.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 443fe3f..51ce0e0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,7 +58,7 @@ option (WITH_SERVICE_BIN "Build LayerManagerService Binary"
option (WITH_CLIENT_LIB "Build LayerManagement Client Lib" ON)
option (WITH_COMMUNICATOR_GEN "Build Generic Communicator Plugin" ON)
-option (WITH_SYSTEMD "Build with native systemd integration" OFF)
+option (WITH_PLUGIN_SYSTEMD_HEALTH_MONITOR "Build plugin for systemd health monitoring" OFF)
option (WITH_TEXT_RENDERER "Build renderer renderer (only logging)" OFF)
@@ -159,6 +159,10 @@ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-unused-function")
#set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
#==============================================================================
+if (WITH_PLUGIN_SYSTEMD_HEALTH_MONITOR)
+ add_subdirectory (LayerManagerPlugins/HealthMonitor/SystemdHealthMonitor)
+endif(WITH_PLUGIN_SYSTEMD_HEALTH_MONITOR)
+
if (WITH_COMMUNICATOR_GEN)
add_subdirectory (LayerManagerCommands)
add_subdirectory (LayerManagerPlugins/Communicators/GenericCommunicator)
@@ -217,5 +221,3 @@ endif (BUILD_UTILS_LIB)
if (WITH_TESTS)
enable_testing()
endif(WITH_TESTS)
-
-