summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Schuldt <michael.schuldt@bmw-carit.de>2011-08-25 13:24:07 +0200
committerMichael Schuldt <michael.schuldt@bmw-carit.de>2011-08-29 11:05:11 +0200
commit020a17fff6a283f99ffe2fd2a72c422ee5f89469 (patch)
tree12af607da65c61567739fe8fd73ae3ffd4c1a498 /CMakeLists.txt
parent0a4a13a3f1133002e015f90774e98ca13ba03927 (diff)
downloadlayer_management-020a17fff6a283f99ffe2fd2a72c422ee5f89469.tar.gz
clean up tests for use with ctest
make ctest setup work again, now 'make test' runs all tests remove unnecessary include file remove -pedantic flag, it is not supported by googletest and googlemock and causes unmanagable number of warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 35ebd83..70a4423 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -68,7 +68,7 @@ option (WITH_GLESv2_LIB
option (WITH_INPUT_EVENTS
"Activate input events handling" OFF)
-set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -pedantic")
+set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra")
option (WITH_FORCE_COPY
"Force Software Copy of Pixmaps" OFF)
@@ -124,5 +124,11 @@ if (WITH_GLX_EXAMPLE)
add_subdirectory (LayerManagerExamples/GLXApplicationExample)
endif(WITH_GLX_EXAMPLE)
+# enable ctest if building with tests
+# run 'make test' after build to run all tests
+# be aware that some tests require a running layermanager
+if (WITH_TESTS)
+enable_testing()
+endif(WITH_TESTS)