summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2018-12-11 10:16:07 +0000
committerEric Engestrom <eric.engestrom@intel.com>2018-12-11 17:46:44 +0000
commit4d67a71d0d034e45059b9eec0749131083e16327 (patch)
tree85e2a1d6c250dc315a658a964d86615be93b1525 /meson.build
parent0f0eb01e8e84bf2335972bdc00fbbba8f6e4ea81 (diff)
downloadkmscube-4d67a71d0d034e45059b9eec0749131083e16327.tar.gz
meson: files should be tracked using `files()`
Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Lyude Paul <lyude@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 679d78c..da7e997 100644
--- a/meson.build
+++ b/meson.build
@@ -32,7 +32,7 @@ if get_option('c_std') != 'c99'
error('c_std must be c99')
endif
-sources = [
+sources = files(
'common.c',
'cube-smooth.c',
'cube-tex.c',
@@ -43,7 +43,7 @@ sources = [
'frame-512x512-NV12.c',
'frame-512x512-RGBA.c',
'kmscube.c',
-]
+)
cc = meson.get_compiler('c')
dep_m = cc.find_library('m', required : false)
@@ -83,7 +83,7 @@ if with_gst != 'false'
if with_gst != 'false'
dep_common += dep_gst
- sources += ['cube-video.c', 'gst-decoder.c']
+ sources += files('cube-video.c', 'gst-decoder.c')
add_project_arguments('-DHAVE_GST', language : 'c')
endif
endif