summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRob Clark <robdclark@chromium.org>2020-02-29 11:16:43 -0800
committerRob Clark <robdclark@chromium.org>2020-03-07 09:22:17 -0800
commit27d4de2bb9bfd9c425848c78d729ba27f9408041 (patch)
treea24b18a3e42fbddce55d9fbc91076a1c62443eec /meson.build
parentf20dc5e295a8605bcbfacbbe487e5452a9e7e312 (diff)
downloadkmscube-27d4de2bb9bfd9c425848c78d729ba27f9408041.tar.gz
add shadertoy mode
Doesn't handle shadertoy shaders which use textures for inputs. That probably wouldn't be straightforward without using the web API to fetch and introspect the shader. But that sounds like a lot more work.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index df9c315..5d7df61 100644
--- a/meson.build
+++ b/meson.build
@@ -35,6 +35,7 @@ endif
sources = files(
'common.c',
+ 'cube-shadertoy.c',
'cube-smooth.c',
'cube-tex.c',
'drm-atomic.c',